Please select To the mobile version | Continue to access the desktop computer version
12Next
Return to list New
View: 1198|Reply: 12

Earlier Model M II not booting now

[Copy link]

1

Threads

8

Posts

45

Credits

Newbie

Rank: 1

Credits
45
Post time 2020-04-13 16:57:24 | Show all posts |Read mode
I bought the M II from Amazon about 6 months ago. The one with red heart shape M II logo on top of the box. It worked just fine for months until I move in to new home recently.

Blue light in the front do not turn on after pressing the on/off button but I do hear a little "Hess" high frequence sound from the box. Nothing display on either HDMI port, no blue light and not booting up. Just nothing happened after turning it on.

Are there tools or guide lines on how to trouble shoot the machine?
Reply

Use magic Report

1

Threads

8

Posts

45

Credits

Newbie

Rank: 1

Credits
45
 Author| Post time 2020-04-13 17:20:12 | Show all posts
I've just checked to confirmed that the model is:

Office Mini PC Beelink M II,Intel Pentium Processor J4205,Memory:8GB,Storage:128GB,2MB Cache,Double HDMI,4K HD,2.4GHz+5.8GHz WiFi,RJ45 1000Mbps LAN,Office Desktop PC

as stated here "https://www.minipc.biz/product/office-mini-pc-beelink-m-iiintel-pentium-processor-j4205memory8gbstorage128gb2mb-cachedouble-hdmi4k-hd2-4ghz5-8ghz-wifirj45-1000mbps-lanoffice-desktop-pc/"
Reply Support Not support

Use magic Report

354

Threads

3193

Posts

9317

Credits

Administrator

Rank: 9Rank: 9Rank: 9

Credits
9317
Post time 2020-04-14 11:29:52 | Show all posts
BitperfectC replied at 2020-04-13 17:20
I've just checked to confirmed that the model is:

Office Mini PC Beelink M II,Intel Pentium Process ...

If the power indicator does not light up, please try to hold down the reset hole for more than five seconds when the power is off, then plug in the power and try to turn on
Reply Support Not support

Use magic Report

1

Threads

8

Posts

45

Credits

Newbie

Rank: 1

Credits
45
 Author| Post time 2020-04-14 15:53:53 | Show all posts
Do you mean to unplug the power cable first before "hold down the reset hole for more than five seconds when the power is off"?
Reply Support Not support

Use magic Report

1

Threads

8

Posts

45

Credits

Newbie

Rank: 1

Credits
45
 Author| Post time 2020-04-14 15:56:50 | Show all posts
Are there user manual I could download which showing how to do clean reset of the box and allow me to restore the windows backup myself?
Reply Support Not support

Use magic Report

354

Threads

3193

Posts

9317

Credits

Administrator

Rank: 9Rank: 9Rank: 9

Credits
9317
Post time 2020-04-15 11:50:16 | Show all posts
BitperfectC replied at 2020-04-14 15:53
Do you mean to unplug the power cable first before "hold down the reset hole for more than five seco ...

After unplugging the power, press and hold the button in the reset hole, the reset hole does not restore the system, if you need a clean system, you need to reinstall the system
Reply Support Not support

Use magic Report

1

Threads

8

Posts

45

Credits

Newbie

Rank: 1

Credits
45
 Author| Post time 2020-04-15 19:06:29 | Show all posts
Thanks for the reply!

Nothing happened by following your instructions. I did unplug the power cable first. Use a pin to press the button inside the hole for over 5 seconds and then release the pin. No blue light, no display from both HDMI ports after press the power button in the back when power cable plugging back in.

What next should I try then?

For your information,  the machine was left in the packing box for 3 months without using or plugging in power. Not sure if this would require some battery to recharge or not before use.
Reply Support Not support

Use magic Report

1

Threads

8

Posts

45

Credits

Newbie

Rank: 1

Credits
45
 Author| Post time 2020-04-15 20:28:34 | Show all posts
Furthermore, I could confirm that the blue light is not dead as it light up a few time in my testing using different combination of holding the reset button together with the power button for different period of time. However, nothing show up on display and doesn't seems operational when blue light is on. Even I could somehow have the blue light turned on but it's not repeatable until somehow another try to get it on.

Reply Support Not support

Use magic Report

354

Threads

3193

Posts

9317

Credits

Administrator

Rank: 9Rank: 9Rank: 9

Credits
9317
Post time 2020-04-16 15:26:06 | Show all posts
BitperfectC replied at 2020-04-15 20:28
Furthermore, I could confirm that the blue light is not dead as it light up a few time in my testing ...

If the blue light still lights up, please try to open the bottom case of the machine, remove the CMOS battery, leave it for 3 minutes to discharge, and then plug in the CMOS battery to turn on to see if it returns to normal.
Reply Support Not support

Use magic Report

1

Threads

8

Posts

45

Credits

Newbie

Rank: 1

Credits
45
 Author| Post time 2020-04-17 02:48:03 | Show all posts
No luck! Nothing change after unplug the battery (there is a plug on motherboard with red/black cable attached to battery) for 5 or 6 mins.

No blue light, no display after plugging in power cord. In fact, the box will power on itselft once power cable plug in. It start to produce the "Hess" sound right the way.

Swith it off and switch it on again make no difference.

Unplug power cable and hold the reset button for 10 sec also make no difference.

What else should I try then?




Reply Support Not support

Use magic Report

12Next
Return to list New
You have to log in before you can reply Login | Sign up

Points Rules

Quick Reply To Top Return to the list