Please select To the mobile version | Continue to access the desktop computer version
View: 2006|Reply: 2

BT 3 Pro II keeps hanging on "Please wait a moment" at set up

[Copy link]

1

Threads

1

Posts

15

Credits

Newbie

Rank: 1

Credits
15
Post time 2020-05-01 23:27:27 | Show all posts |Read mode
Dear people,

We sell a lot of Beelink computers but we found a problem with the BT 3 Pro II. Some clients experience the problem during the set up (at the beginning when you need to make an account or log in with your Windows account). When they are at the point to make a Pin Code, the system says "Please wait a moment". You can't go further because the Windows isn't loading further, you simply only see "Please wait a moment". The system doesn't freeze but it doesn't go to the next step of the account set up.

Can anyone help me out with this please? We see that his problem occurs more at newer batches.

Kind regards,

J. Grgic
Majstra
Reply

Use magic Report

1

Threads

6

Posts

39

Credits

Newbie

Rank: 1

Credits
39
Post time 2020-05-04 04:25:51 | Show all posts
per the manual/book one thing is DONT connect to the internet on setup
Reply Support Not support

Use magic Report

0

Threads

3

Posts

18

Credits

Newbie

Rank: 1

Credits
18
Post time 2020-09-20 23:10:41 | Show all posts
Hi

I had the same problem.  Apparently, the pin code dialog window is hidden, and it is not possible to get it to the front using alt-TAB.

I got around it by opening the on-screen keyboard, then using alt-TAB to select the pin code dialog window (you will not see it), and then start using the on-screen keyboard to type your pin code, then TAB, then your pin code again, and then Enter.  You are basically entering the info blind.  The installation continued successfully after doing this.  Note that it took me several tries to get this right.

Best regards,

Marcus
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Sign up

Points Rules

Quick Reply To Top Return to the list