Please select To the mobile version | Continue to access the desktop computer version
View: 1649|Reply: 8

Green screen after update to CoreELEC 9.2.4

[Copy link]

10

Threads

22

Posts

172

Credits

Member

Rank: 2

Credits
172
Post time 2020-08-09 22:41:53 | Show all posts |Read mode
Edited by CastagnaIT at 2020-08-10 20:26

After the update to CoreElec 9.2.4
sometimes at startup of the device the screen remains all green, no logo, no menus, so only green color
and nothing can be done only press power button to shutdown

after another startup it start working again

Reply

Use magic Report

10

Threads

22

Posts

172

Credits

Member

Rank: 2

Credits
172
 Author| Post time 2020-08-16 19:06:56 | Show all posts
Edited by CastagnaIT at 2020-08-16 19:11
spikerguy replied at 2020-08-15 08:55
What do you mean same model with different hardware?

the units sent to users as free for tests or for awards
has not completely equal hardware to regular (commercial version) of GS-King X

running tests with CoreElec devs we saw that this type of units
has a hardware version similar to GT King X
and this is the cause of the bootloader issues when you use DTB of regular GS King X.

To new CoreELEC releases a new DTB will be available for GS King X (called rev a) to be used with these particular test units

---

Also the green screen will be resolved to new releases,
this fix in some cases unfortunately could cause a short delay with Kodi startup

Reply Support 1 Not support 0

Use magic Report

357

Threads

3311

Posts

9699

Credits

Administrator

Rank: 9Rank: 9Rank: 9

Credits
9699
Post time 2020-08-10 09:19:04 | Show all posts
Sorry, we recommend that you go to coreelec's forum for this question. It is difficult for us to help you solve this problemOr you can provide me with a video or picture, we will see if we can help you
Reply Support Not support

Use magic Report

10

Threads

22

Posts

172

Credits

Member

Rank: 2

Credits
172
 Author| Post time 2020-08-10 20:20:02 | Show all posts
Edited by CastagnaIT at 2020-08-10 20:27

heh there is nothing to see...
when you turn on the device just after Beelink logo at boot, the screen become all green
you can only turn off by pressing the button on the box or unplung the power cable

I will try to see the coreelec forum

PS. i meant last ver 9.2.4
Reply Support Not support

Use magic Report

357

Threads

3311

Posts

9699

Credits

Administrator

Rank: 9Rank: 9Rank: 9

Credits
9699
Post time 2020-08-11 09:13:24 | Show all posts
CastagnaIT replied at 2020-08-10 20:20
heh there is nothing to see...
when you turn on the device just after Beelink logo at boot, the scre ...

If you can't  find a suitable solution in the coreelec forum, please contact us again
Reply Support Not support

Use magic Report

10

Threads

22

Posts

172

Credits

Member

Rank: 2

Credits
172
 Author| Post time 2020-08-12 02:20:49 | Show all posts
I have been contacted by CE devs
if some other want see discussion to the problem see here:
https://discourse.coreelec.org/t ... -screen-issue/12492

We are resolving the problem of the failed LibreELEC boot on some of these devices with different hardware revision.

A suggestion for Beelink company:
if you have to cooperate with CoreELEC Team at least
you can inform the CoreELEC Team that you produce the same unit with different hardware
and save to everyone a lot of trouble and time losed...

For the green screen problem, will come later
Reply Support Not support

Use magic Report

7

Threads

197

Posts

1007

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
1007
Post time 2020-08-15 08:55:13 From the mobile phone | Show all posts
What do you mean same model with different hardware?
Reply Support Not support

Use magic Report

1

Threads

99

Posts

759

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
759
Post time 2020-08-15 15:16:08 | Show all posts
Edited by darkstar at 2020-08-20 05:21

This problem is related to 9.2.4 if it is not working solution is pretty simple use 9.2.4.1 or 9.2.3 versions.

I tried Nightly Build and there is no such issue, it ran smoothly.

Reply Support Not support

Use magic Report

3

Threads

14

Posts

87

Credits

Member

Rank: 2

Credits
87
Post time 2020-08-19 20:20:53 | Show all posts
I'm running 9.2.4.2 with a revA processor and it is running fine (9.2.4.2 comes with a GS-King X revA DTB file).
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Sign up

Points Rules

Quick Reply To Top Return to the list